[blfs-dev] llvm-3.5.1 fails to build on 686

Bruce Dubbs bruce.dubbs at gmail.com
Tue Jan 20 23:45:22 PST 2015


Ken Moffat wrote:
> On Mon, Jan 19, 2015 at 09:30:37PM -0600, Bruce Dubbs wrote:
>> Armin K. wrote:
>>>
>>> gcc-4.7.0 might be way too old. LLVM makes use of C++11, which
>>> gcc-4.7.0, as far as I know, doesn't support that well. But, it has been
>>> known that .0 releases of gcc can be buggy, so have you tried upgrading
>>> to latest 4.7.x release available?
>>
>> I guess I can try installing the latest gcc to /opt (or /usr/local) and then
>> use that.
>>
>> Actually this is just to test texlive and xindy.  I don't really need it
>> otherwise.
>>
>   Thanks, but I'm puzzled - I always build llvm on desktops, for
> Mesa, but I put it in /opt and keep it off $PATH except when
> building Mesa.  Which dep is implying that it might be useful for
> texlive or xindy ?

llvm (clang) is optional for icu and that is recommended for texlive.

   -- Bruce




More information about the blfs-dev mailing list