[blfs-dev] llvm-3.5.1 fails to build on 686

Armin K. krejzi at email.com
Mon Jan 19 18:52:27 PST 2015


On 01/20/2015 03:26 AM, Bruce Dubbs wrote:
> llvm[2]: Compiling LexicalScopes.cpp for Release build
> LexicalScopes.cpp:
> 
> In constructor 'std::pair<_T1, _T2>::pair(std::piecewise_construct_t,
>                                           std::tuple<_Args1 ...>,
>                                           std::tuple<_Args2 ...>)
> 
> [with _Args1 = {llvm::MDNode*};
>       _Args2 = {llvm::LexicalScope*,
>                 llvm::DIDescriptor,
>                 std::nullptr_t, bool};
>       _T1 = const llvm::MDNode* const;
>       _T2 = llvm::LexicalScope]'
> :
> LexicalScopes.cpp:351:1: internal compiler error: in
> type_contains_placeholder_1, at tree.c:2957
> 
> I'm using gcc-4.7.0.
> 
> Have we seen this before?  Google does not seem to help on this one.
> 
>   -- Bruce

gcc-4.7.0 might be way too old. LLVM makes use of C++11, which
gcc-4.7.0, as far as I know, doesn't support that well. But, it has been
known that .0 releases of gcc can be buggy, so have you tried upgrading
to latest 4.7.x release available?

-- 
Note: My last name is not Krejzi.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-dev/attachments/20150120/42c78848/attachment.sig>


More information about the blfs-dev mailing list