[blfs-dev] intel xorg driver

Ken Moffat zarniwhoop at ntlworld.com
Tue Jan 13 17:47:23 PST 2015


On Tue, Jan 13, 2015 at 05:30:32PM -0600, Bruce Dubbs wrote:
> Ken Moffat wrote:
> 
> >
> >  From memory, glamor (i.e. now xorg-server with glamor built-in) is
> >still required for Southern Islands and Sea Islands and NOT needed
> >for the earlier versions.  And for nouveau, I believe someone said
> >glamor was for the latest hardware.
> >
> >  So, what sort of change did you have in mind ?
> 
> For ATI, we have:
> 
> cat >> /etc/X11/xorg.conf << "EOF"
> Section "Module"
>         Load "dri2"
>         Load "glamoregl"
> EndSection
> 
> Section "Device"
>         Identifier "radeon"
>         Driver "radeon"
>         Option "AccelMethod" "glamor"
> EndSection
> EOF
> 
> I think, as a minimum, that the module section is no longer needed.  The
> Device section narrows the driver to just radeon as you described, but I
> don't know if the option is needed or not any more.
> 
>   -- Bruce
> 

 I read the whole section in the ATI driver beginning "Glamor
Acceleration" as essentially applying only to Southern Islands and
later (very recent AMD APUs, particularly those at the top of the
range, and some high-end video cards).

 I _suspect_ that those devices do not now need xorg.conf, but I do
not have the hardware to test that.  Getting one of the APUs is on
my list of "things to consider", but for the moment I have not been
convinced.  I think somebody said he has one, maybe Conathan ?

ĸen
-- 
Nanny Ogg usually went to bed early. After all, she was an old lady.
Sometimes she went to bed as early as 6 a.m.


More information about the blfs-dev mailing list