[blfs-dev] ... r15279 - in trunk/BOOK: . introduction/welcome kde/core

Fernando de Oliveira famobr at yahoo.com.br
Sat Jan 10 10:47:47 PST 2015


On 04-01-2015 08:17, Armin K. wrote:
> On 12/29/2014 08:14 PM, fernando at higgs.linuxfromscratch.org wrote:
>> Author: fernando
>> Date: Mon Dec 29 11:14:35 2014
>> New Revision: 15279
>>
>> Log:
>> Update to phonon-backend-gstreamer-4.8.2.
>> phonon-4.8.3: format and qt dependencies.
>>
>> Modified:
>>    trunk/BOOK/introduction/welcome/changelog.xml
>>    trunk/BOOK/kde/core/phonon-backend-gstreamer.xml
>>    trunk/BOOK/kde/core/phonon.xml
>>    trunk/BOOK/packages.ent
>>

>> Modified: trunk/BOOK/kde/core/phonon-backend-gstreamer.xml
>> ==============================================================================
>> --- trunk/BOOK/kde/core/phonon-backend-gstreamer.xml	Mon Dec 29 04:15:04 2014	(r15278)
>> +++ trunk/BOOK/kde/core/phonon-backend-gstreamer.xml	Mon Dec 29 11:14:35 2014	(r15279)


>>      <bridgehead renderas="sect4">Recommended</bridgehead>
>>      <para role="recommended">
>> +    <xref linkend="gobject-introspection"/>,
> 
> This one isn't used by the package at all. It only uses
> libgobject-2.0.so from glib-2.0.
> 

>> +    <xref linkend="libxml2"/>
>> +    </para>

> libxml2 is required, not recommended.
> 
> From CmakeLists.txt:
> 
> find_package(LibXml2 REQUIRED)
> macro_log_feature(LIBXML2_FOUND "LibXml2" "LibXml2 is required to
> compile the gstreamer backend for Phonon"
> "http://xmlsoft.org/downloads.html" TRUE)

Missed that. Thanks.

>> +    <bridgehead renderas="sect4">Optional</bridgehead>
>> +    <para role="optional">
>> +    <xref linkend="qt5"/>
>>      </para>
> 
> Ragnar dropped Qt5 dependencies in favor of Phonon that is part of the
> KDE 5 section (not yet in main BLFS).

?

>> Modified: trunk/BOOK/kde/core/phonon.xml
>> ==============================================================================
>> --- trunk/BOOK/kde/core/phonon.xml	Mon Dec 29 04:15:04 2014	(r15278)
>> +++ trunk/BOOK/kde/core/phonon.xml	Mon Dec 29 11:14:35 2014	(r15279)

> You also need cmake.

This I forgot to add and I or someone else forgot before, when automoc
was commented out.


>> +      <xref linkend="qt5"/> and
> 
> Same as above.

Same as above.

Fixed at revision 15321 ?

-- 
[]s,
Fernando


More information about the blfs-dev mailing list