[blfs-dev] polkit-1.0.6

Armin K. krejzi at email.com
Tue Jul 3 16:43:47 PDT 2012


On 3.7.2012 22:51, Bruce Dubbs wrote:
> I ran into two problems with polkit.   First, the default instructions
> failed to make the man pages because I had a problem with my xml
> configuration.
>
> /usr/bin/xsltproc -nonet --stringparam man.base.url.for.relative.links
> /usr/share/gtk-doc/html/polkit-1/ --xinclude
> http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
> polkit.xml
>
> warning: failed to load external entity
> "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
> cannot parse
> http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
>
> I can bypass this with --disable-man-pages, and fixing the xml
> configuration also worked.  However we may want to add
> --disable-man-pages as a part of the default instructions.  On the other
> hand, we do say that docbook-xml and docbook-xsl are required if libsxlt
> is installed and that may be enough.  It *is* reasonable to assume that
> dependent packages are installed properly (which mine weren't).
>

Why should we disable something by default if that works with the 
current instructions? It is clearly said that docbook-xml and 
docbook-xsl are required if libxslt is installed. I would rather suggest 
expanding the note saying that if libxslt is installed, but docbook 
stuff isn't present someone could add --disable-man-pages.

>
>
> Second, I get a test failure:
>
> /PolkitBackendJsAuthority/get_admin_identities: Error getting system
> bus: Could not connect: No such file or directoryError loading
> /var/run/ConsoleKit/database: Error statting file
> /var/run/ConsoleKit/database: No such file or directory
> **
> (/tmp/polkit/polkit-0.106/test/polkitbackend/.libs/lt-polkitbackendjsauthoritytest:98
>
> I have not installed consolekit.  Is it a runtime dependency that needs
> to be mentioned?  Note that I am building KDE and consolekit is only
> mentioned in kde4workspace, but policykit is needed for polkit-qt.
>

Search the -support for the same problem. It is D-Bus that is problem, 
not ConsoleKit. And it is a bad thing recommending consolekit, since 
polkit is recommended for consolekit. It would be catch-22 situation. 
You can pass test without consolekit running, but not without d-bus running.

Error getting system bus: Could not connect: No such file or directory. 
is the actual problem.



More information about the blfs-dev mailing list