[blfs-dev] Problems with 7.2-rc1

Ken Moffat zarniwhoop at ntlworld.com
Fri Aug 31 17:05:10 PDT 2012

On Tue, Aug 28, 2012 at 04:50:56AM +0100, Ken Moffat wrote:
>  Overall this is looking good.  I've still got a few things to build
> (boost - apparently it will need to be upgraded for glibc-2.16.0),
> gnash, and a little of xfce (for parole and xfburn).

 Suppose I ought to follow up.  Still a few things I haven't tested,
but I've got one problem that I might be local, and some notes on
boost and gnash.

 First, what I hope is a local problem : /dev/sr0 is owned by
root:cdrom with mode 660.  /dev/cdrom links to it and I'm in the
cdrom group.  But when I use cdrdao, writing only works for root.
Weird, but it isn't something I've done before on this machine,
perhaps it's not even a new problem.

Boost : Both 1_51_0 and the book's 1_50_0 build, but
"threading-multi" is not a valid target and stops the install. I've
now found out that the build can be separated from the install by
just running ./b2 - the benefit of this is that you can pass -jN for
a parrallel make, which helps.  For the moment, I'm not in a hurry
to fix that because I only build boost for gnash - see next para.

Gnash : With both these versions of boost, it fails to link, two
errors like
/usr/bin/ld: processor.o: undefined reference to symbol
/usr/bin/ld: note: '_ZN5boost6system15system_categoryEv' is defined
in DSO /usr/lib/../lib64/libboost_system.so.1.51.0 so try adding it
to the linker command line
/usr/lib/../lib64/libboost_system.so.1.51.0: could not read symbols:
Invalid operation
collect2: error: ld returned 1 exit status

 That is fixed by this sed:
sed -i '/^LIBS/s/\(.*\)/\1 -lboost_system/' \
  gui/Makefile.in utilities/Makefile.in

 I've no idea if it was gcc-4.7 or glibc-2.16.0 which caused that
change, but gcc seems more likely.

 Last time I built gnash, it didn't have much use for me as a
firefox plugin.  At that time, Andy was around and he confirmed it
worked for him.  Since then, I've discovered that I hadn't installed
all of the necessary headers, so I was hopeful that this build would
be more useful.  But it does next to nothing - enough for firefox to
recognise it as a plugin for flash, but nothing I tried did
anything, and even the "hear before you buy" flash clips at linn
records didn't work this time.  So, I know how to build it, but
(like transcode, where I'm still exploring the options), I can't say
it works, and I think that labelling it as built but not tested
would be misleading.

 Boost is also usable by cairomm, inkscape, libreoffice, abiword,
and several kde packages.  Perhaps they too will need to be fixed.
I started to look at abiword (boost is for the collab plugin), but
it failed badly with errors about asio not being defined in scope
(the normal build without collab is fine).  Nothing on google, so I
thought that a development release might be better for building the
collab plugin, but abisource.com wasn't responding and I ran out of

 Unfortunately, I don't have any more time to spend on BLFS re 7.2,
except for testing some server packages and adding more tags for the
things that worked.

das eine Mal als Tragödie, das andere Mal als Farce

More information about the blfs-dev mailing list