lfs 6.2-pre1 and people with glibc-2.4

Bruce Dubbs bruce.dubbs at gmail.com
Wed Jul 19 09:36:25 PDT 2006


Joe Ciccone wrote:
> Guys, in #lfs-support on irc I see 3 people building 6.2 -pre1 with
> glibc-2.4 right now. Now, those are the only 3 that said it, there may
> be more. The instructions work and it's not going to break anything
> while building the base system but, later when they try to run, mainly
> samba, it's not going to work. Samba is the only package I've seen this
> in but I know there are more. I'm just giving you the heads up on an
> error that I think you're going to be seeing a lot of in the future.
> 
> smbd: gconv_db.c:232: __gconv_release_step: Assertion `step->__end_fct
> == ((void *)0)' failed.
> all 3, smbd, nmbd, and winbindd all show this error when starting up
> with a empty LANG env variable.
> 
> This patch fixes the issue and a re-compile of glibc is needed.
> http://www.linuxfromscratch.org/patches/downloads/glibc/glibc-2.4-iconv_fix-1.patch
> 
> NOTE: This patch is needed _only_ with glibc-2.4 and is fixed upstream.

Thanks Joe.  I'm cross posting to lfs-dev as that is where this
discussion should be.

I have no problem with putting this patch in the book's trunk, but of
course we are not going to update to glibc-2.4 for the lfs-6.2 release.
 There are currently about a dozen packages to update in the LFS trunk
so I suspect we will see several more problems of this type.

  -- Bruce



More information about the blfs-dev mailing list