rep-gtk make error with gtk-2.4

Tushar Teredesai tushar at linuxfromscratch.org
Sat Mar 27 23:10:09 PST 2004


jeff wrote:

> Just doing a new install of blfs-cvs and get this error when trying to 
> run make on rep-gtk
>
> In file included from rep-types.c:24:
> rep-gtk.h:294: error: conflicting types for 
> `gtk_radio_menu_item_new_with_label_from_widget'
> /usr/include/gtk-2.0/gtk/gtkradiomenuitem.h:79: error: previous 
> declaration of `gtk_radio_menu_item_new_with_label_from_widget'
> rep-gtk.h:297: error: conflicting types for 
> `gtk_radio_menu_item_new_with_mnemonic_from_widget'
> /usr/include/gtk-2.0/gtk/gtkradiomenuitem.h:77: error: previous 
> declaration of `gtk_radio_menu_item_new_with_mnemonic_from_widget'
> make: *** [rep-types.lo] Error 1

I also found that some packages had problems with 2.4.x. On my system I 
have downgraded back to the 2.2.x.

-- 
Tushar Teredesai
   http://linuxfromscratch.org/~tushar/
   http://www.geocities.com/tushar/




More information about the blfs-dev mailing list