libao needs --disable-alsa09

Michael T. Dean mtdean at thirdcontact.com
Fri Mar 12 10:26:38 PST 2004


Michael Brömer wrote:

>Am Freitag, 12. März 2004 16:18 schrieb jeff:
>  
>
>>libao fails to compile with the new
>>alsa-1.0.2c unless you add the
>>--disable-alsa09 to the configure script
>>    
>>
>
>Passing CPPFLAGS="-DALSA_PCM_OLD_HW_PARAMS_API"
>to configure works for me.
>
>Unfortunately i did not take a note where i got this from...
>  
>
Also, CVS version builds fine.  I know, I know.  We only use released 
versions for the book, but interestingly enough, the top of CHANGES shows

0.8.5 - March 12, 2004
- Support now for the ALSA 1.0 API

So maybe we'll see a new release today (unless, of course, someone is 
updating the date in CHANGES everyday :).

Mike Dean



More information about the blfs-dev mailing list