Subversion

Matthew Burgess matthew at linuxfromscratch.org
Wed Jun 23 10:33:39 PDT 2004


On Wed, 23 Jun 2004 11:18:14 -0400
Anderson Lizardo <lizardo at linuxfromscratch.org> wrote:

> On Tuesday 22 June 2004 22:32, DJ Lucas wrote:
> > Jeremy Huntwork wrote:
> > > Another hint: Python and SWIG are needed if you want to use trac
> > > as a front-end. (In addition to a couple other packages.) I'm not
> > > sure if that's true for other similar programs...
> >
> > So with this tidbit, Apache, J2SDK, and neon are server-only
> > optional deps.  All others are used for both client and server.  No
> > sense trying to use external APR as newer functions are needed from
> > the in-tree copy.
> >   In-tree apr-utils also needs a patch for db-4.2.x.
> 
> Just a warning: If you have Apache already installed (with
> apr/apr-utils support), when you install svn, it will try to overwrite
> some files from the Apache installation. The solution I've found was
> to remove the apr/apr-utils dirs from the svn tree, forcing it to use
> Apache's versions.

You could always use `./configure --help` which would show the
'--with-apr=' and '--with-apr-util=' options :)



More information about the blfs-dev mailing list