Berkeley DB

Tushar Teredesai tushar at linuxfromscratch.org
Wed Apr 16 06:30:04 PDT 2003


Greg Schafer wrote:

>db-3.1.7 thing for evo seems the right way to go.
>
That is already done. Evolution uses the static lib built by db-3.1.7.

>For the rest, in the past I have installed db-4 then done something like:-
>
>ln -sf libdb-4.0.so /usr/lib/libdb-3.so &&
>mkdir -p /usr/include/db3 &&
>ln -sf ../db.h /usr/include/db3
>
It would be much cleaner (given the changes between versions) to either 
install the actual db3 libraries or not install them at all and (when 
required) patch packages that depend on db3 to use db-4.1.

>then everything that goes looking for db-3 ('cept evo) just works. Maybe it
>won't with latest db-4.1. Dunno.
>  
>
Most probably it won't work with db-4.1.x owing to the change in API 
(some functions have a transaction id as an additional parameter).

-- 
Tushar Teredesai
   http://www.linuxfromscratch.org/~tushar/
   http://www.geocities.com/tushar/


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list