XFree DRI modules hit by versioning

Ken Moffat ken at kenmoffat.uklinux.net
Fri Apr 11 13:47:42 PDT 2003


Hi,

 For the first time since I got a video card which supports dri, I'm
rebuilding the kernel (with a different extraversion) after I've built
X.

 I remembered "Warning  If you recompile or upgrade your kernel you will
need to re-copy the driver modules to the kernel module library and
rerun depmod" and did this, but the required module (radeon) still
failed to load.  It was only when I modprobed it that I got an error
message that it had been compiled for a different version of the kernel.

 Yeah, my fault for forgetting that I use module versioning when I first
read this, but it might be worth flagging up that copying the driver
modules is no use if you are using module versioning ?

 Looks like dri won't build if you don't make world first, so I'll be
rebuilding X tonight :-(

Ken
-- 
 Out of the darkness a voice spake unto me, saying "smile, things could be
worse". So I smiled, and lo, things became worse.



-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list