[blfs-book] r21001 - trunk/BOOK/multimedia/audioutils

renodr at higgs.linuxfromscratch.org renodr at higgs.linuxfromscratch.org
Sat Jan 19 10:51:47 PST 2019


Author: renodr
Date: Sat Jan 19 10:51:47 2019
New Revision: 21001

Log:
Remove obsolete i686 build instruction in LAME

Modified:
   trunk/BOOK/multimedia/audioutils/lame.xml

Modified: trunk/BOOK/multimedia/audioutils/lame.xml
==============================================================================
--- trunk/BOOK/multimedia/audioutils/lame.xml	Sat Jan 19 10:27:26 2019	(r21000)
+++ trunk/BOOK/multimedia/audioutils/lame.xml	Sat Jan 19 10:51:47 2019	(r21001)
@@ -90,15 +90,6 @@
     <title>Installation of LAME</title>
 
     <para>
-      First, fix a compiler error introduced by
-      <application>gcc-4.9.0</application> on 32-bit machines:
-    </para>
-
-<screen><userinput>case $(uname -m) in
-   i?86) sed -i -e 's/<xmmintrin.h/&.nouse/' configure ;;
-esac</userinput></screen>
-
-    <para>
       Install <application>LAME</application> by running
       the following commands:
     </para>
@@ -122,16 +113,6 @@
     <title>Command Explanations</title>
 
     <para>
-      <command>sed -i -e 's/<xmmintrin.h/&.nouse/' configure</command> : with
-      gcc-4.9.0 and above, the compiler issues an error on 32-bit machines,
-      while compiling <filename>xmm_quantize_sub.c</filename>. The error
-      message is: <literal>error: inlining failed in call to always_inline
-      '_mm_loadu_ps'</literal>. This sed makes it appear as if
-      <filename>xmmintrin.h</filename> is not present. Do not use this on other
-      versions of gcc.
-    </para>
-
-    <para>
       <parameter>--enable-mp3rtp</parameter>: This switch enables building
       the encode-to-RTP program.
     </para>


More information about the blfs-book mailing list