[blfs-book] [BLFS Trac] #9738: vala-0.38.0 will not build without graphviz

BLFS Trac via blfs-book blfs-book at lists.linuxfromscratch.org
Sat Sep 9 10:18:16 PDT 2017


#9738: vala-0.38.0 will not build without graphviz
--------------------+-----------------------
 Reporter:  renodr  |       Owner:  bdubbs@…
     Type:  defect  |      Status:  assigned
 Priority:  normal  |   Milestone:  8.2
Component:  BOOK    |     Version:  SVN
 Severity:  normal  |  Resolution:
 Keywords:          |
--------------------+-----------------------

Comment (by pierre.labastie):

 What's wrong with requiring graphviz as a dependency? Usually, we do not
 go much against upstream decisions, even if we do not agree with them.
 Graphviz is not such a big package, that we might be reluctant to build
 it...

 Anyway, I've already fixed the book, adding graphviz to required
 dependencies. If there is a consensus against that, please feel free to
 remove it. But my opinion is just that it will make the page more
 complicated for not much gain.

--
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/9738#comment:4>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch


More information about the blfs-book mailing list