[blfs-book] [BLFS Trac] #7591: Stop recommending gobject-introspection

BLFS Trac trac at linuxfromscratch.org
Thu Mar 17 02:00:10 PDT 2016


#7591: Stop recommending gobject-introspection
-------------------------+--------------------------
 Reporter:  ken@…        |       Owner:  blfs-book@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  7.10
Component:  BOOK         |     Version:  SVN
 Severity:  normal       |  Resolution:
 Keywords:               |
-------------------------+--------------------------

Comment (by pierre.labastie):

 Well, g-i is one of those packages that becomes really required very late
 (and for very few applications), but needs to be built early to be useful
 (because .gir files have to be built for many packages used by those
 applications). Up to now, recommending it for gtk+ has seemed to be a good
 solution.

 I'd rather see the deps remain as they are. At least, whether in
 recommended or optional, the wording should be changed to (Required if you
 plan to build packages in the "Gnome Applications" section, or Midori).

--
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/7591#comment:2>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch


More information about the blfs-book mailing list