[blfs-book] [BLFS Trac] #7580: webkitgtk+-2.4.10

BLFS Trac trac at linuxfromscratch.org
Wed Mar 16 07:34:54 PDT 2016


#7580: webkitgtk+-2.4.10
-----------------------------+------------------------------
 Reporter:  pierre.labastie  |       Owner:  pierre.labastie
     Type:  enhancement      |      Status:  assigned
 Priority:  high             |   Milestone:  7.10
Component:  BOOK             |     Version:  SVN
 Severity:  normal           |  Resolution:
 Keywords:                   |
-----------------------------+------------------------------

Comment (by pierre.labastie):

 According to [https://blogs.gnome.org/mcatanzaro/2016/02/01/on-webkit-
 security-updates/ this] blogpost, webkitgtk+-2.4 should not be used for
 web browsing. I think I've found that Midori can use the webkit2gtk-4.0
 API (that is webkitgtk+-2.8.10) by passing ''-DHALF_BRO_INCOMP_WEBKIT2'',
 but the name of the switch looks scarry! On the other hand, browsing the
 web with insecure browsers is scarry too... ANyway, I'll test midori with
 this switch, and report here.

--
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/7580#comment:2>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch


More information about the blfs-book mailing list