XML/XSL

M.Canales.es manuel at linuxfromscratch.org
Fri Sep 15 11:43:01 PDT 2006


El Viernes, 15 de Septiembre de 2006 03:51, George Boudreau escribió:

>   It is not obvious to the user that they need libxml2, libxslt, DocBook
> DTD, DocBook XSL Stylesheets and HTMLTidy installed.

For libxml2 >= 2.6.20 , libxslt >= 1.1.14 (xsltproc --version will show both) 
and tidy (any post 1st September 2004 works)  a check like the current ones 
for jhalfs dependencies is enough.

For the DTD and XSL the unique way I can think to be sure that both have the 
correct version and are properly installed is running a test-case. For that, 
a very simple XML document and XSL stylesheet need be created (maybe via here 
documents dumped to temp files), running xmllint and xsltproc on then, 
analyzing the output for errors.

I will try to create that test-cases this weekend while the box will be busy 
doing new makefile builds.

-- 
Manuel Canales Esparcia
Usuario de LFS nº2886:       http://www.linuxfromscratch.org
LFS en castellano: http://www.escomposlinux.org/lfs-es http://www.lfs-es.info
TLDP-ES:                           http://es.tldp.org



More information about the alfs-discuss mailing list